Abstract

These Application Notes describe the procedures for configuring Session Initiation Protocol (SIP) Trunking between Service Provider Intelepeer and Avaya IP Office 7.0.

Intelepeer SIP Trunking provides PSTN access via a SIP trunk between the enterprise and the Intelepeer network as an alternative to legacy analog or digital trunks. This approach generally results in lower costs for the enterprise.

Intelepeer is a member of the Avaya DevConnect Service Provider program. Information in these Application Notes has been obtained through DevConnect compliance testing and additional technical discussions. Testing was conducted via the DevConnect Program at the Avaya Solution and Interoperability Test Lab.
1. Introduction

These Application Notes describe the procedures for configuring Session Initiation Protocol (SIP) Trunking between Service Provider Intelepeer and an Avaya IP Office solution. In the sample configuration, the Avaya IP Office solution consists of an Avaya IP Office 500v2 Release 7.0, Avaya Voicemail Pro, Avaya IP Office Softphone, and Avaya SIP, H.323, digital, and analog endpoints.

The Intelepeer SIP Trunking service referenced within these Application Notes is designed for business customers. The service enables local and long distance PSTN calling via standards-based SIP trunks as an alternative to legacy analog or digital trunks, without the need for additional TDM enterprise gateways and the associated maintenance costs.

The Intelepeer SIP Trunking service does not require the enterprise IP PBX to register with the SIP network via SIP credentials. Customers are authenticated via IP authentication.

2. General Test Approach and Test Results

The general test approach was to configure a simulated enterprise site using Avaya IP Office to connect to Intelepeer SIP Trunking service. This configuration (shown in Figure 1) was used to exercise the features and functionality tests listed in Section 2.1.

2.1. Interoperability Compliance Testing

A simulated enterprise site with Avaya IP Office was connected to Intelepeer SIP Trunking service. To verify SIP trunking interoperability, the following features and functionality were exercised during the interoperability compliance test:

- Response to SIP OPTIONS queries.
- Incoming PSTN calls to various phone types. Phone types included SIP, H.323, digital, and analog telephones at the enterprise. All inbound PSTN calls were routed to the enterprise across the SIP trunk from the Service Provider.
- Outgoing PSTN calls from various phone types. Phone types included SIP, H.323, digital, and analog telephones at the enterprise. All outbound PSTN calls were routed from the enterprise across the SIP trunk to the Service Provider.
- Inbound and outbound PSTN calls to/from the Avaya IP Office Softphone.
- Inbound and outbound long hold time call stability.
- Various call types including: local, long distance, international, outbound toll-free, operator service and directory assistance.
- Codec G.711MU and G.729A.
- Caller number/ID presentation.
- Privacy requests (i.e., caller anonymity) and Caller ID restriction for inbound and outbound calls.
- DTMF transmission using RFC 2833.
- Voicemail navigation for inbound and outbound calls.
- Telephony features such as hold and resume, transfer, and conference.
- Off-net call forwarding.
- Twinning to mobile phones on inbound calls.
2.2. Test Results
Intelepeer SIP Trunking passed compliance testing. Items not supported or not tested included the following:

- Inbound toll-free and outbound emergency calls (911) are supported but were not tested as part of the compliance test.
- Operator (0) calls, Operator Assisted (0+10 digits) dialing and 411 / 1411 services are not supported and therefore were not tested.

Interoperability testing of Intelepeer SIP Trunking was completed with successful results for all test cases.

2.3. Support
For technical support on the Avaya products described in these Application Notes visit http://support.avaya.com.

For technical support on Intelepeer SIP Trunking, contact Intelepeer at http://www.Intelepeer.com/ or 1-866-780-8639.
3. Reference Configuration

Figure 1 below illustrates the test configuration. The test configuration shows an enterprise site connected to Intelepeer SIP Trunking service through the public IP network. Located at the enterprise site is an Avaya IP Office 500v2 with the COMBO6210/ATM4 expansion card which provides connections for 6 digital stations, 2 analog stations, 4 analog trunks to the PSTN as well as 10-channel VCM (Voice Compression Module) for supporting VoIP codecs. The LAN port of Avaya IP Office is connected to the enterprise LAN while the WAN port is connected to the public IP network. Endpoints include an Avaya 1600 Series IP Telephone (with H.323 firmware), an Avaya 1120e Series IP Telephone (with SIP firmware), an Avaya 1408 Digital Telephone, an Avaya Analog Telephone and an Avaya IP Office Softphone. The site also has a Windows 2003 Server running Avaya Voicemail Pro for providing voice messaging service to the Avaya IP Office users. A separate Windows XP PC runs Avaya IP Office Manager to configure and administer the Avaya IP Office system. Mobility Twinning is configured for some of the Avaya IP Office users so that calls to these user’s phones will also ring and can be answered at the configured mobile phones.

Figure 1: Test Configuration for Avaya IP Office with Intelepeer SIP Trunking Service
For security purposes, the real public IP addresses and PSTN routable phone numbers used in the compliance test are masked in these Application Notes.

For the purposes of the compliance test, Avaya IP Office users dialed a short code of \(9 + N\) digits to send digits across the SIP trunk to Intelepeer. The short code of 9 was stripped off by Avaya IP Office but the remaining N digits were sent unaltered to Intelepeer. For calls within the North American Numbering Plan (NANP), the user would dial 11 \((1 + 10)\) digits. Thus for these NANP calls, Avaya IP Office would send 11 digits in the Request URI and the To headers of an outbound SIP INVITE message. IP Office was configured to send 10 digits in the From and PAI headers. For inbound calls, Intelepeer SIP Trunking sent 10 digits in the Request URI, To, and From headers of inbound SIP INVITE messages.

In an actual customer configuration, the enterprise site may also include additional network components between the Service Provider and Avaya IP Office such as a Session Border Controller or data firewall. A complete discussion of the configuration of these devices is beyond the scope of these Application Notes. However, it should be noted that SIP and RTP traffic between the Service Provider and Avaya IP Office must be allowed to pass through these devices.

### 4. Equipment and Software Validated

The following equipment and software/firmware were used for the sample configuration provided:

<table>
<thead>
<tr>
<th>Avaya Telephony Components</th>
<th>Release</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avaya IP Office 500v2</td>
<td>7.0 (5)</td>
</tr>
<tr>
<td>Avaya IP Office COMBO6210/ATM4 Module</td>
<td>7.0 (5)</td>
</tr>
<tr>
<td>Avaya Voicemail Pro</td>
<td>7.0.17</td>
</tr>
<tr>
<td>Avaya IP Office Manager</td>
<td>9.0 (5)</td>
</tr>
<tr>
<td>Avaya 1616 IP Telephone (H.323)</td>
<td>Avaya one-X Deskphone Value Edition 1.2.2</td>
</tr>
<tr>
<td>Avaya 1120E IP Telephone (SIP)</td>
<td>SIP1120 version 04.01.13.00</td>
</tr>
<tr>
<td>Avaya 1408 Digital Telephone</td>
<td>N/A</td>
</tr>
<tr>
<td>Avaya Analog Telephone</td>
<td>N/A</td>
</tr>
<tr>
<td>Avaya IP Office Softphone</td>
<td>3.1.2.17 59616</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Intelepeer SIP Trunking</th>
<th>Release</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sonus GSX9000HD</td>
<td>Version: V07.03.04 S003</td>
</tr>
</tbody>
</table>
5. Configure Avaya IP Office

This section describes the Avaya IP Office configuration necessary to support connectivity to Intelepeer SIP Trunking service. Avaya IP Office is configured through the Avaya IP Office Manager PC application. From a PC running the Avaya IP Office Manager application, select Start → Programs → IP Office → Manager to launch the application. Navigate to File → Open Configuration, select the proper Avaya IP Office system from the pop-up window, and log in with the appropriate credentials. A management window will appear similar to the one shown in the next section. The appearance of the IP Office Manager can be customized using the View menu. In the screens presented in this section, the View menu was configured to show the Navigation pane on the left side, the Group pane in the center, and the Details pane on the right side. These panes will be referenced throughout the Avaya IP Office configuration. Proper licensing as well as standard feature configurations that are not directly related to the interface with the Service Provider (such as LAN interface to the enterprise site and IP Office Softphone support) is assumed to be already in place.

5.1. LAN2 Settings

In the sample configuration, the MAC address 00E00705B33F was used as the system name and the WAN port (LAN2) was used to connect the Avaya IP Office to the public network. The LAN2 settings correspond to the WAN port on the Avaya IP Office system. To access the LAN2 settings, first navigate to System (1) → 00E00705B33F in the Navigation and Group Panes respectively, and then navigate to the LAN2 → LAN Settings tab in the Details Pane. Set the IP Address field to the IP address assigned to the Avaya IP Office WAN port. Set the IP Mask field to the mask used on the public network. All other parameters should be set according to customer requirements. Click “OK” when finished and Save the configuration.
Select the **VoIP** tab as shown in the following screen. The **SIP Trunks Enable** box must be checked to enable the configuration of SIP trunks to Intelepeer. The **RTP Port Number Range** can be customized to a specific range of receive ports for the RTP media. Based on this setting, Avaya IP Office would request RTP media be sent to a UDP port in the configurable range for calls using LAN2. Avaya IP Office can also be configured to mark the Differentiated Services Code Point (DSCP) in the IP Header with specific values to support Quality of Services policies for both signaling and media. The **DSCP** field is the value used for media and the **SIG DSCP** is the value used for signaling. To prevent possible loss of audio path during some call forward off-net scenarios, it is recommended to set the following fields under **RTP Keepalives**: Set **Scope** to **RTP**, **Initial keepalives** to **Enable** and an appropriate **Periodic timeout** from 1 to 180 seconds. The specific values used for the compliance test are shown in the example below. All other parameters should be set according to customer requirements.
On the **Network Topology** tab in the Details Pane, configure the following parameters:

- **Select the Firewall/NAT Type** from the pull-down menu that matches the network configuration. No firewall or network address translation (NAT) device was used in the compliance test as shown in Figure 1, so the parameter was set to **Open Internet**. With this configuration, STUN will not be used.

- **Set Binding Refresh Time (seconds)** to **60**. This value is used as one input to determine the frequency at which Avaya IP Office will send SIP OPTIONS messages to the Service Provider. See **Section 5.10** for complete details.

- **Set Public IP Address** to the IP address of the Avaya IP Office WAN port.

- All other parameters should be set according to customer requirements.

- Click “OK” when finished and Save the configuration.

![Network Topology Configuration](image)

In the compliance test, the LAN1 interface was used to connect the Avaya IP Office to the enterprise site IP network. The LAN1 interface configuration is not directly relevant to the interface with Intelepeer SIP Trunking service, and therefore is not described in these Application Notes.
5.2. System Telephony Settings

Navigate to the Telephony → Telephony Tab in the Details Pane. Set the Automatic Codec Preference for the default codec to be used for intra-enterprise traffic. Choose the Companding Law typical for the enterprise location. For North America, *ULAW* is used. Uncheck the Inhibit Off-Switch Forward/Transfer box to allow call forwarding and call transfer to the PSTN via the Service Provider across the SIP trunk.
5.3. Twinning Calling Party Settings

When using twinning, the calling party number displayed on the twinned phone is controlled by two parameters. The first parameter is the **Send original calling party information for Mobile Twinning** box on the System->Twinning tab. The second parameter is the **Send Caller ID** parameter on the SIP Line form (shown in Section 5.4). If Send original calling party information for Mobile Twinning on the System->Twinning tab is set, the setting of the second parameter is ignored and Avaya IP Office will send the following in the SIP From Header:

- On calls from an internal extension to a twinned phone, Avaya IP Office will send the calling party number of the originating extension.
- On calls from the PSTN to a twinned phone, Avaya IP Office will send the calling party number of the host phone associated with the twinned destination (instead of the number of the originating caller).

The above behavior in Avaya IP Office Release 7 is the same as in Avaya IP Office Release 6 and was tested and verified in the compliance test. Avaya IP Office Release 7 also provides an alternative method of sending caller ID through SIP Diversion header (configured via unchecking Send original calling party information for Mobile Twinning here then selecting Diversion Header for the Send Caller ID parameter on the SIP Line form in Section 5.4). This alternative configuration could provide more accurate caller ID information if the Service Provider supports the SIP Diversion header (not tested in the compliance test). For the compliance test, the Send original calling party information for Mobile Twinning box in the System->Twinning tab was checked which overrides any setting of the Send Caller ID parameter on the SIP Line form.
5.4. Administer SIP Line

A SIP line is needed to establish the SIP connection between Avaya IP Office and Intelepeer SIP Trunking service. To create a SIP line, begin by navigating to Line in the left Navigation Pane, then right-click in the Group Pane and select New -> SIP Line. On the SIP Line tab in the Details Pane, configure the parameters as shown below:

- Set ITSP Domain Name to the enterprise domain, or the IP address of the IP Office WAN interface, so that IP Office uses this domain / IP address as the host portion of SIP URI in SIP headers such as the From header.
- Set Send Caller ID to None. For the compliance test, this parameter was ignored since Send original calling party information for Mobile Twinning is optioned in Section 5.3.
- Check the In Service box.
- Check the Check OOS box. With this option selected, Avaya IP Office will use the SIP OPTIONS method to periodically check the SIP Line.
- Default values may be used for all other parameters.

The area of the screen entitled REFER Support is used to enable/disable SIP REFER for call transfers. If “REFER Support” is left unchecked, or the fields for Incoming and Outgoing are set to “Auto”, this will effectively disable the use of SIP REFER. To enable SIP REFER, check the “REFER Support” button and select “Always” from the drop-down menu for Incoming and Outgoing.
Select the **Transport** tab. The **ITSP Proxy Address** is set to the Intelepeer SIP Proxy IP Address provided by Intelepeer. As shown in **Figure 1**, this IP Address is **68.1.1.41**. In the **Network Configuration** area, **UDP** is selected as the **Layer 4 Protocol**, and the **Send Port** is set to the port number provided by Intelepeer. The **Use Network Topology Info** parameter is set to **LAN 2**. This associates the SIP Line with the parameters in the **System → LAN2 → Network Topology** tab. Other parameters retain default values in the screen below.

![SIP Line - Line 18*](image)
A SIP URI entry must be created to match each incoming number that Avaya IP Office will accept on this line. Select the SIP URI tab, then click the Add button and the New Channel area will appear at the bottom of the pane. To edit an existing entry, click an entry in the list at the top, and click the Edit... button. In the example screen below, a previously configured entry is edited. For the compliance test, a single SIP URI entry was created that matched any DID number assigned to an Avaya IP Office user. The entry was created with the parameters shown below:

- Set Local URI, Contact and Display Name to Use Internal Data. This setting allows calls on this line for SIP URIs that match the number set in the SIP tab of any User as shown in Section 5.6.
- Set PAI to Use Internal Data. With this setting Avaya IP Office will populate the SIP P-Asserted-Identity header on outgoing calls with the data set in the SIP tab of the User initiating the call as shown in Section 5.6.
- For Registration, select None since Intelepeer doesn’t require Registration. If Registration was required, then the account credentials that would have been configured on the line's SIP Credentials tab would be entered here.
- Associate this line with an incoming line group in the Incoming Group field. This line group number will be used in defining incoming call routes for this line. Similarly, associate the line to an outgoing line group using the Outgoing Group field. For the compliance test, a new incoming and outgoing line group 18 was defined.
- Set Max Calls per Channel to the number of simultaneous SIP calls that are allowed using this SIP URI pattern.
Select the **VoIP** tab to set the Voice over Internet Protocol parameters of the SIP line. Set the parameters as shown below:

- **The Compression Mode** was configured using the **Advanced** button, allowing an explicit ordered list of codecs to be specified. Check marks next to **G.729(a) 8K CS-ACELP** and **G.711 U/LAW** codecs cause Avaya IP Office to include these codes, supported by the Intelepeer SIP Trunking service, in the Session Description Protocol (SDP) offer, in that order.
- Set the **DTMF Support** field to **RFC2833**. This directs Avaya IP Office to send DTMF tones using RTP event messages as defined in RFC2833.
- Uncheck the **VoIP Silence Suppression** box. By unchecking the **VoIP Silence Suppression** box, calls can be established with the G.729 codec but without silence suppression.
- Select **T.38** for **Fax Transport Support**. T.38 faxing is supported by Intelepeer and was successfully tested.
- Check the **Re-invite Supported** box.
- Default values may be used for all other parameters.
5.5. Short Code

Define a short code to route outbound traffic to the SIP line. To create a short code, select Short Code in the left Navigation Pane, then right-click in the Group Pane and select New. On the Short Code tab in the Details Pane, configure the parameters for the new short code to be created. The screen below shows the details of the previously administered “9N;” short code used in the test configuration.

- In the Code field, enter the dial string which will trigger this short code, followed by a semi-colon. In this case, 9N;. This short code will be invoked when the user dials 9 followed by any number.
- Set Feature to Dial. This is the action that the short code will perform.
- Set Telephone Number to N*@68.1.1.41”. This field is used to construct the Request URI and To headers in the outgoing SIP INVITE message. The value N represents the number dialed by the user. The host part following the “@” is the domain or IP address of the Service Provider network.
- Set the Line Group Id to the outgoing line group number defined on the SIP URI tab on the SIP Line in Section 5.4. This short code will use this line group when placing the outbound call.

---

<table>
<thead>
<tr>
<th>IP Offices</th>
<th>Short Code</th>
<th>9N@ Dial</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code</td>
<td>Feature</td>
<td>Telephone Number</td>
</tr>
<tr>
<td>9N</td>
<td>Dial</td>
<td>N*@68.1.1.41”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Line Group Id</td>
</tr>
<tr>
<td></td>
<td></td>
<td>18</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Local</td>
</tr>
<tr>
<td></td>
<td></td>
<td>United States (US English)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Force Account Code</td>
</tr>
</tbody>
</table>
The simple “9N;” short code illustrated above does not provide a means of alternate routing if the configured SIP Line is out of service or temporarily not responding. When alternate routing options and/or more customized analysis of the digits following the short code are desired, the Automatic Route Selection (ARS) feature may be used. In the following example screen, the short code 6N is illustrated for access to ARS. When the Avaya IP Office user dials 6 plus any number N, rather than being directed to a specific Line Group Id, the call is directed to Line Group ID “50: Main”, configurable via ARS. See Section 5.8 for example ARS route configuration for “50: Main” as well as a backup route.
5.6. User

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP line defined in Section 5.4. To configure these settings, first select User in the left Navigation Pane, then select the name of the user to be modified in the center Group Pane. In the example below, the name of the user is “H323 1616”. Select the SIP tab in the Details Pane.

The values entered for the SIP Name and Contact fields are used as the user part of the SIP URI in the From header for outgoing SIP trunk calls. They also allow matching of the SIP URI for incoming calls without having to enter this number as an explicit SIP URI for the SIP line (Section 5.4). The example below shows the settings for user H323 1616. The SIP Name and Contact are set to one of the DID numbers assigned to the enterprise from Intelepeer. The SIP Display Name (Alias) parameter can optionally be configured with a descriptive name. If all calls involving this user and a SIP Line should be considered private, then the Anonymous box may be checked to withhold the user’s information from the network.
One of the H.323 IP Phones at the enterprise site uses the Mobile Twinning feature. The following screen shows the Mobility tab for User H323 1616. The Mobility Features and Mobile Twinning boxes are checked. The Twinned Mobile Number field is configured with the number to dial to reach the twinned mobile telephone. Other options can be set according to customer requirements.
5.7. Incoming Call Route

An incoming call route maps an inbound DID number on a specific line to an internal extension. This procedure should be repeated for each DID number provided by the Service Provider. To create an incoming call route, select **Incoming Call Route** in the left Navigation Pane, then right-click in the center Group Pane and select **New**. On the **Standard** tab of the Details Pane, enter the parameters as shown below:

- Set the **Bearer Capacity** to *Any Voice*.
- Set the **Line Group Id** to the incoming line group of the SIP line defined in **Section 5.4**.
- Set the **Incoming Number** to the incoming number on which this route should match.
- Default values can be used for all other fields.

On the **Destinations** tab, select the destination extension from the pull-down menu of the **Destination** field. In this example, incoming calls to 303-555-9132 on line 18 are routed to user the Avaya 1616-I H.323 endpoint at extension 301.
5.8. ARS and Alternate Routing

While detailed coverage of Automatic Route Selection (ARS) is beyond the scope of these Application Notes, this section includes basic ARS screen illustrations and considerations. ARS is illustrated here mainly to illustrate alternate routing should the SIP Line be out of service or temporarily not responding.

Optionally, ARS can be used rather than the simple “9N;” short code approach documented in Section 5.5. With ARS, a secondary dial tone can be provided after the access code, time-based routing criteria can be introduced, and alternate routing can be specified so that a call can re-route automatically if the primary route or outgoing line group is not available. Although not shown in this section, ARS also facilitates more specific dialed telephone number matching, enabling immediate routing and alternate treatment for different types of numbers following the access code. For example, if all 1+10 digit calls following an access code should use the SIP Line preferentially, but other local or service numbers following the access code should prefer a different outgoing line group, ARS can be used to distinguish between these call behaviors.

To add a new ARS route, right-click ARS in the Navigation pane, and select New. To view or edit an existing ARS route, select ARS in the Navigation pane, and select the appropriate route name in the Group pane.

The following screen shows an example ARS configuration for the route named “Main”. The In Service parameter refers to the ARS form itself, not the Line Groups that may be referenced in the form. If the In Service box is un-checked, calls are routed to the ARS route name specified in the Out of Service Route parameter. IP Office short codes may also be defined to allow an ARS route to be disabled or enabled from a telephone. The configurable provisioning of an Out of Service Route, and the means to manually activate the Out of Service Route, can be helpful for scheduled maintenance or other known service-affecting events for the primary route.
Assuming the primary route is in-service, the number passed from the short code used to access ARS (e.g., 6N in Section 5.5) can be further analyzed to direct the call to a specific Line Group ID. Per the example screen above, if the user dialed 6-1-303-555-1234, the call would be directed to Line Group 18, the SIP Line configured and described in these Application Notes. If Line Group 18 cannot be used, the call can automatically route to the route name configured in the Additional Route parameter in the lower right of the screen (not configured for the compliance test). Since alternate routing can be considered a privilege not available to all callers, Avaya IP Office can control access to the alternate route by comparing the calling user’s priority to the value in the Alternate Route Priority Level field.

5.9. Privacy/Anonymous Calls

For outbound calls with privacy (anonymous) enabled, Avaya IP Office will replace the calling party number in the From and Contact headers of the SIP INVITE message with “restricted” and “anonymous” respectively. Avaya IP Office can be configured to use the P-Preferred-Identity (PPI) or P-Asserted-Identity (PAI) header to pass the actual calling party information for authentication and billing. For the compliance test, PAI was used for the purposes of privacy.

To configure Avaya IP Office to use PAI for privacy calls, navigate to User → NoUser in the Navigation / Group Panes. Select the Source Numbers tab in the Details Pane. Click the Add button.

At the bottom of the Details Pane, the Source Number field will appear. Enter SIP_USE_PAI_FOR_PRIVACY. Click OK.
The SIP_USE_PAI_FOR_PRIVACY parameter will appear in the list of Source Numbers as shown below.

5.10. SIP Options
Avaya IP Office sends SIP OPTIONS messages periodically to determine if the SIP connection is active. The rate at which the messages are sent is determined by the combination of the Binding Refresh Time (in seconds) set on the Network Topology tab in Section 5.1 and the SIP_OPTIONS_PERIOD parameter (in minutes) that can be set on the Source Number tab of the NoUser user. The OPTIONS period is determined in the following manner:

- If no SIP_OPTIONS_PERIOD parameter is defined and the Binding Refresh Time is 0, then the default value of 42 seconds is used.
- To establish a period less than 42 seconds, do not define a SIP_OPTIONS_PERIOD parameter and set the Binding Refresh Time to a value less than 42 secs. The OPTIONS message period will be equal to the Binding Refresh Time.
- To establish a period greater than 42 seconds, a SIP_OPTIONS_PERIOD parameter must be defined. The Binding Refresh Time must be set to a value greater than 42 secs. The OPTIONS message period will be the smaller of the Binding Refresh Time or the SIP_OPTIONS_PERIOD.

To configure the SIP_OPTIONS_PERIOD parameter, navigate to User → noUser in the Navigation / Group Panes. Select the Source Numbers tab in the Details Pane. Click the Add button.
At the bottom of the Details Pane, the **Source Number** field will appear. Enter **SIP_OPTIONS_PERIOD=X**, where $X$ is the desired value in minutes. Click **OK**.

![Image of Source Number field](image1)

The **SIP_OPTIONS_PERIOD** parameter will appear in the list of Source Numbers as shown below. For the compliance test, an OPTIONS period of 1 minute was desired. The **Binding Refresh Time** was set to 60 seconds (1 minute) in [Section 5.1](#) and the **SIP_OPTIONS_PERIOD** was set to 1 minute. Avaya IP Office chose the OPTIONS period as the smaller of these two values (1 minute was the OPTIONS period since they were both set equal to 1 minute). Click the **OK** button (not shown).

![Image of Source Numbers list](image2)

**5.11. Save Configuration**

Navigate to **File → Save Configuration** in the menu bar at the top of the screen to save the configuration performed in the preceding sections.
6. Intelepeer SIP Trunking Configuration

Intelepeer is responsible for the configuration of Intelepeer SIP Trunking service. The customer will need to provide the IP address and / or FQDN used to reach the Avaya IP Office at the enterprise. Intelepeer will provide the customer the necessary information to configure the Avaya IP Office SIP connection to Intelepeer. The provided information from Intelepeer includes:

- IP address of the Intelepeer SIP proxy
- Intelepeer SIP domain
- Supported codecs
- DID numbers
- IP addresses, port numbers and transport protocol used for signaling or media through any security devices

7. Verification Steps

The following steps may be used to verify the configuration:

- Use the Avaya IP Office System Status application to verify the state of the SIP connection. Launch the application from Start → Programs → IP Office → System Status on the PC where Avaya IP Office Manager was installed. Select the SIP line of interest from the left pane. On the Status tab in the right pane, verify that the Current State is Idle for each channel (assuming no active calls at present time).

- Select the Alarms tab and verify that no alarms are active on the SIP line.
- Verify that a phone connected to the PSTN can successfully place a call to the Avaya IP Office with two-way audio.
- Verify that a phone connected to Avaya IP Office can successfully place a call to the PSTN with two-way audio.
  1. Using a network sniffing tool (e.g., Wireshark), monitor the SIP signaling messages between Intelepeer and Avaya IP Office on an outbound call from the enterprise to the PSTN.

8. Conclusion

Intelepeer SIP Trunking passed compliance testing. These Application Notes describe the procedures required to configure the SIP trunk connection between Avaya IP Office and the Intelepeer SIP Trunking service as shown in Figure 1. Please refer to Section 2.2 above for Test Results and any Limitations that were observed.

9. Additional References

This section references the documentation relevant to these Application Notes. Additional Avaya product documentation is available at [http://support.avaya.com](http://support.avaya.com).


Product documentation for Avaya products may be found at [http://support.avaya.com](http://support.avaya.com). Additional IP Office documentation can be found at:

Product documentation for Intelepeer SIP Trunking is available from Intelepeer.
©2012 Avaya Inc. All Rights Reserved.
Avaya and the Avaya Logo are trademarks of Avaya Inc. All trademarks identified by ® and ™ are registered trademarks or trademarks, respectively, of Avaya Inc. All other trademarks are the property of their respective owners. The information provided in these Application Notes is subject to change without notice. The configurations, technical data, and recommendations provided in these Application Notes are believed to be accurate and dependable, but are presented without express or implied warranty. Users are responsible for their application of any products specified in these Application Notes.

Please e-mail any questions or comments pertaining to these Application Notes along with the full title name and filename, located in the lower right corner, directly to the Avaya DevConnect Program at devconnect@avaya.com.